Frieve EffeTune 
Процессор аудиоэффектов реального времени для аудиоэнтузиастов, которые хотят сделать прослушивание музыки ещё лучше. EffeTune позволяет пропускать звук из любого источника через разнообразные высококачественные эффекты и настраивать звучание под себя в реальном времени.
Вводное видео
Концепция
EffeTune создан для аудиоэнтузиастов, которые хотят улучшить прослушивание музыки. Независимо от того, слушаете ли вы стриминг или воспроизводите музыку с физических носителей, EffeTune позволяет добавлять высококачественные эффекты и настраивать звук под свои предпочтения. Превратите компьютер в мощный процессор аудиоэффектов между источником звука и колонками или усилителем.
Без аудиофильских мифов, только чистая наука.
Особенности
- Обработка аудио в реальном времени
- Интерфейс drag-and-drop для создания цепочек эффектов
- Расширяемая система эффектов с категоризированными эффектами
- Визуализация аудио в реальном времени
- Настраиваемые композиции Visualizer с анимированными графиками, обложкой и сведениями о треке
- Аудиотракт, который можно изменять в реальном времени
- Офлайн обработка аудиофайлов с использованием текущей цепочки эффектов
- Музыкальная библиотека для просмотра локальных подпапок, метаданных и плейлистов
- Компактный мини-плеер поверх всех окон для настольного приложения
- Измерение и коррекция частотной характеристики для калибровки системы
- Многоканальная обработка и вывод
- Удобный интерфейс веб-приложения для телефонов и планшетов
Руководство по настройке
Выберите ниже способ настройки для источника звука, который хотите слушать.
Настройка проигрывателя музыкальных файлов
- Откройте веб-приложение EffeTune в браузере или запустите настольное приложение EffeTune
- Откройте и воспроизведите музыкальный файл для проверки правильности воспроизведения
- Нажмите кнопку Открыть музыкальные файлы и выберите музыкальный файл
- Или откройте музыкальный файл и выберите EffeTune в качестве приложения (только для настольного приложения)
- Или выберите Открыть музыкальный файл… из меню Файл (только для настольного приложения)
- Или перетащите музыкальный файл в окно
- Если EffeTune нужен только как проигрыватель, выберите в окне Настройка аудио для параметра Входное устройство: значение Нет (только проигрыватель музыкальных файлов), чтобы не использовать внешний аудиовход. Это значение по умолчанию в настольном приложении. Если вы уже сохранили выбор входного устройства, приложение продолжит использовать его.
Встроенный браузер настольного приложения
В настольном приложении Браузер позволяет слушать звук с сайтов через текущую цепочку эффектов без виртуального аудиоустройства.
- Нажмите Браузер в заголовке. Начнётся обработка звука браузера.
- Введите адрес HTTP или HTTPS, войдите в аккаунт и запустите музыку средствами сайта. Если протокол не указан, используется HTTPS.
- Переключитесь на Effect Pipeline, чтобы настроить звук. При смене экрана звук браузера продолжает воспроизводиться.
Используйте Назад, Вперёд, Обновить и Остановить загрузку для навигации. Откройте Закладки, чтобы добавить текущую страницу, открыть сохранённую, переименовать закладку или удалить её. В меню браузера доступны Открыть в браузере по умолчанию, Сделать стартовой страницей и Очистить данные сайтов. Закладки и стартовая страница сохраняются. Вход в учётные записи на сайтах сохраняется отдельно и доступен после перезапуска приложения. Масштаб страниц в браузере соответствует масштабу приложения.
При открытии раздела Браузер или возвращении в него звук браузера выбирается автоматически. Звук браузера смешивается со звуком выбранного устройства ввода. Выберите Нет для устройства ввода, чтобы слушать только браузер. Параметр аудиовхода проигрывателя не влияет на воспроизведение в браузере. Локальная музыка может воспроизводиться одновременно со звуком браузера. Если захват звука прервался, нажмите Браузер ещё раз. Очистить данные сайтов выполняет выход из учётных записей и удаляет сохранённые данные сайтов, оставляя закладки.
Нажмите Закрыть на панели инструментов браузера, чтобы остановить обработку его звука и вернуться в Effect Pipeline. Страница и история просмотра сохраняются. Откройте Браузер снова, чтобы возобновить обработку звука на той же странице.
В разделе Настройки > Конфигурация… > Браузер доступны следующие параметры:
- Начальная страница — HTTP- или HTTPS-адрес страницы, которая появляется при первом открытии браузера. По умолчанию поле пустое; если оно пустое, открывается руководство EffeTune по стримингу. Кнопка Сбросить очищает поле, не меняя текущую страницу.
- Открывать новые вкладки в браузере по умолчанию — включено по умолчанию. Отключите этот параметр, чтобы такие ссылки открывались в браузере приложения EffeTune. Отдельные окна, например для входа в аккаунт, в обоих случаях остаются внутри EffeTune.
- User-Agent — строка, по которой сайты определяют браузер. По умолчанию браузер представляется совместимым с Chrome, а строка также содержит название EffeTune. Оставьте поле пустым или нажмите Сбросить, чтобы восстановить значение по умолчанию. После изменения перезагрузите страницу в браузере.
Некоторые сайты запрещают встроенные браузеры, вход в аккаунт, защищённое воспроизведение или захват звука. Доступность зависит от сайта и ОС; воспроизведение с DRM не гарантируется. Если вход запрещён, попробуйте другой способ, предложенный сайтом, или обычный браузер. Вход в обычном браузере не выполняет вход внутри EffeTune. Браузер доступен только в настольном приложении.
Настройка расширения браузера
Обрабатывайте до четырёх вкладок Chrome или Edge с отдельными цепочками эффектов, выбором пресета по URL и настройкой частоты дискретизации без виртуального аудиоустройства. См. руководство по расширению браузера.
- Установите расширение EffeTune из магазина Chrome или Edge.
- Запустите воспроизведение во вкладке, звук которой хотите обработать, откройте EffeTune на панели инструментов браузера и выберите Start on this tab.
- Выберите Edit pipeline, чтобы добавить эффекты и настроить звук.
Настройка потокового сервиса
Для обработки аудио из потоковых сервисов (Spotify, YouTube Music и т.д.):
В настольном приложении сначала попробуйте встроенный браузер. Для отдельного приложения потокового сервиса или источника, который встроенный браузер не воспроизводит, используйте настройку аудиоустройства ниже.
- Необходимые условия:
- Установите виртуальное аудио устройство (например, VB Cable, Voice Meeter или ASIO Link Tool)
- Настройте ваш потоковый сервис на вывод аудио через виртуальное устройство
- Конфигурация:
- Откройте веб-приложение EffeTune в браузере или запустите настольное приложение EffeTune
- Выберите виртуальное аудио устройство в качестве источника входного сигнала
- В Chrome при первом открытии появится диалоговое окно с запросом на выбор и разрешение аудио входа
- Откройте Настройка аудио… в меню Настройки, чтобы выбрать устройства ввода/вывода и формат аудио
- Начните воспроизведение музыки из вашего потокового сервиса
- Убедитесь, что аудио проходит через EffeTune
- Подробные инструкции по настройке см. в FAQ
Настройка физического аудио источника
Чтобы использовать EffeTune с CD-плеерами, сетевыми плеерами или другими физическими источниками:
- Подключите аудиоинтерфейс к вашему компьютеру
- Откройте веб-приложение EffeTune в браузере или запустите настольное приложение EffeTune
- Выберите ваш аудиоинтерфейс в качестве источника входного и выходного сигнала
- В Chrome при первом открытии появится диалоговое окно с запросом на выбор и разрешение аудио входа
- Откройте Настройка аудио… в меню Настройки, чтобы выбрать устройства ввода/вывода и формат аудио
- Теперь ваш аудиоинтерфейс функционирует как многоэффектный процессор:
- Вход: CD-плеер, сетевой плеер или другой источник звука
- Обработка: эффекты в реальном времени в EffeTune
- Выход: обработанный звук на усилитель или колонки
Использование
При первом запуске краткий обзор покажет, где воспроизводить музыку, добавлять эффекты и настраивать звук. Обзор можно повторить в любое время: выберите Обзор приложения в меню настроек, в меню Помощь настольного приложения или через кнопку меню на мобильном устройстве.
Создание цепочки эффектов
- Доступные эффекты перечислены в левой части экрана
- Используйте кнопку поиска рядом с “Available Effects”, чтобы отфильтровать эффекты
- Введите текст для поиска эффектов по названию или категории
- Нажмите ESC, чтобы очистить поиск
- Перетащите эффекты из списка в область Effect Pipeline
- На мобильном устройстве откройте вкладку Эффекты и нажмите кнопку +, чтобы добавить эффекты из полноэкранного списка
- Эффекты обрабатываются в порядке сверху вниз
- Перетащите маркер (⋮) или нажмите кнопки ▲▼ для изменения порядка эффектов
- Для эффектов Section: Shift+нажатие кнопок ▲▼ для перемещения целых секций (от одной Section к следующей Section, начало цепочки или конец цепочки)
- Нажмите на название эффекта, чтобы развернуть/свернуть его настройки
- Shift+нажатие на эффект Section сворачивает/разворачивает все эффекты в этой секции
- Shift+нажатие на другие эффекты сворачивает/разворачивает все эффекты, кроме категории Analyzer
- Ctrl+нажатие сворачивает/разворачивает все эффекты
- Используйте кнопку ON, чтобы обходить отдельные эффекты
- Нажмите кнопку ? для открытия подробной документации в новой вкладке
- Удалите эффекты, используя кнопку ×
- Для эффектов Section: Shift+нажатие кнопки × для удаления целых секций
- Нажмите кнопку маршрутизации, чтобы настроить каналы для обработки и входные и выходные шины
- Нажмите кнопку Пресеты эффекта у эффекта, чтобы сохранить или применить настройки только для этого эффекта
Поиск музыки в музыкальной библиотеке
Вы можете организовать музыкальные файлы, хранящиеся на вашем устройстве, в библиотеку.
- Откройте Музыкальная библиотека кнопкой в заголовке на ПК, вкладкой Библиотека в мобильном интерфейсе или через Вид > Музыкальная библиотека в настольном приложении.
- Выберите Добавить папку с музыкой, чтобы проиндексировать папку с музыкальными файлами. Внешние файлы CUE позволяют разделить альбомные файлы WAV или FLAC из той же папки на отдельные треки.
- Просматривайте разделы Треки, Альбомы, Исполнители, Жанры, Подпапки, Папки, Недавно добавлено или Плейлисты и фильтруйте коллекцию с помощью поля Поиск в библиотеке.
- Нажмите Воспроизвести, чтобы слушать через текущую цепочку эффектов, или управляйте воспроизведением с помощью Воспроизвести следующим, Добавить в очередь и Добавить в плейлист.
- После изменения файлов используйте Пересканировать; если разрешения браузера или папки истекли, используйте Подключить заново.
Visualizer
Вы можете наслаждаться визуализациями на основе воспроизводимой музыки.
Откройте Visualizer в верхней части окна на ПК, на мобильной вкладке Плеер или через меню настольного приложения Вид. Выберите встроенную композицию или нажмите Edit, чтобы расположить графики звука, обложку и сведения о треке. Изменения видны сразу и возвращаются при следующем запуске; именованную копию сохраните в окне пресетов. Наведите курсор на область отображения или коснитесь её и выберите ⛶, чтобы развернуть её на всё окно приложения. Подробнее о редактировании, эффектах и настройках отображения — в руководстве Visualizer.
Использование пресетов
Вы можете сохранять и загружать созданные цепочки эффектов.
Нажмите кнопку Пресеты цепочки эффектов в заголовке Effect Pipeline, чтобы открыть диалог пресетов.
- Загрузите пресет, выбрав его в списке сохранённых пресетов. Восстанавливается вся цепочка, включая порядок эффектов, настройки и состояния ON/OFF.
- Сохраните текущую цепочку, введя название и выбрав Сохранить.
- Переименуйте сохранённый пресет кнопкой переименования в его строке.
- Выберите один или несколько сохранённых пресетов, затем выберите Удалить выбранные и подтвердите удаление.
- Нажмите Ctrl+S (или Cmd+S в macOS), чтобы открыть диалог с готовым к редактированию именем текущего пресета.
У каждого эффекта также есть собственная кнопка Пресеты эффекта. Она открывает системные пресеты, когда эффект их предоставляет, и позволяет сохранять, переименовывать, загружать или удалять ваши настройки для этого эффекта. Пресеты эффекта меняют только его параметры, но не состояние ON/OFF и не маршрутизацию.
Импорт, экспорт и обмен файлами .effetune_preset по-прежнему относятся к пресетам полной цепочки эффектов.
Общие элементы управления эффектами
- Для точной настройки ползунка удерживайте Shift при перетаскивании; значение будет изменяться на один минимальный шаг
- У ползунков с отрицательными и положительными значениями заливка идёт от 0 до текущего значения. У ползунков Ratio она начинается от 1.0.
- На поддерживаемых графиках с осью частот или нот перетаскивайте указатель вдоль оси, чтобы прослушать выбранную частоту через цепочку эффектов. В Конфигурация > Общие > Звук прослушивания частоты выберите Синусоидальный сигнал (по умолчанию, -12 дБ) или Полосовой шум, сосредоточенный вокруг выбранной частоты. Note Spectrogram, Pitch Meter, Chroma Spiral и клавиатуры фортепиано всегда используют синусоидальный сигнал. При отображении клавиатуры частота привязывается к ближайшему полутону; перетаскивание по клавише воспроизводит её ноту
Управление эффектами через MIDI, геймпад или клавиатуру
Использование функций Section
Вы можете объединять несколько эффектов в группу и управлять ими вместе.
- Использование эффекта Section:
- Добавьте эффект Section в начале группы эффектов
- Введите описательное название в поле Comment
- Переключение ON/OFF эффекта Section обходит или возвращает всю секцию, сохраняя собственное состояние ON/OFF каждого эффекта
- Используйте несколько эффектов Section для организации вашей цепочки эффектов в логические группы
- Подробнее о управлении эффектами
Использование функций AB Pipeline
Вы можете переключаться между двумя цепочками эффектов и сравнивать их звучание.
- Обзор AB Pipeline:
- EffeTune может поддерживать два отдельных конвейера эффектов: Pipeline A и Pipeline B
- При запуске загружается только Pipeline A; Pipeline B создается при необходимости
- Все операции обработки, сохранения, загрузки и редактирования работают на текущем выбранном конвейере
- Кнопка переключения AB:
- Расположена справа от заголовка Effect Pipeline
- По умолчанию показывает “A” (Pipeline A активен)
- Нажмите для переключения между Pipeline A и Pipeline B
- Если Pipeline B не существует при переключении, настройки Pipeline A копируются в Pipeline B
- Меню AB (Выпадающая кнопка):
- Расположено справа от кнопки переключения AB
- “A → B”: Копирует настройки Pipeline A в Pipeline B и переключается на Pipeline B
- “B → A”: Копирует настройки Pipeline B в Pipeline A и переключается на Pipeline A
- Двойной слепой тест:
- Сравнивайте Pipeline A и Pipeline B, не зная, какой из них сейчас воспроизводится
- Выполните ABX-тест, чтобы проверить, действительно ли вы различаете две цепочки эффектов, или A/B-тест предпочтения, чтобы выяснить, какой вариант вам нравится больше, с проверкой статистической значимости
- Открывается из меню цепочки ▼ справа от кнопки переключения AB (в настольном приложении также доступно из меню Файл)
- Подробнее о двойном слепом тесте
Выбор эффектов и горячие клавиши
- Методы выбора эффектов:
- Кликните по заголовкам эффектов, чтобы выбрать отдельные эффекты
- Удерживайте Ctrl при клике для выбора нескольких эффектов
- Кликните по пустому пространству в области Pipeline, чтобы снять выбор со всех эффектов
- Горячие клавиши:
- Ctrl + Z: Отменить
- Ctrl + Y: Повторить
- Ctrl + S: Сохранить текущую цепочку
- Ctrl + Shift + S: Сохранить текущую цепочку как
- Ctrl + X: Вырезать выбранные эффекты
- Ctrl + C: Копировать выбранные эффекты
- Ctrl + V: Вставить эффекты из буфера обмена
- Ctrl + F: Найти эффекты
- Ctrl + A: Выбрать все эффекты в цепочке
- Delete: Удалить выбранные эффекты
- ESC: Снять выделение со всех эффектов
- T: Переключиться между Pipeline A и Pipeline B
- A: Переключиться на Pipeline A
- B: Переключиться на Pipeline B
- Горячие клавиши (при использовании проигрывателя):
- Space: Воспроизведение/Пауза
- Ctrl + → или N: Следующий трек
- Ctrl + ← или P: Предыдущий трек
- Shift + → или F или .: Перемотка вперёд на 10 секунд
- Shift + ← или R или ,: Перемотка назад на 10 секунд
- Ctrl + M: Включить/выключить режим повтора
- Ctrl + H: Включить/выключить случайный порядок
- T: Переключиться между Pipeline A и Pipeline B
- A: Переключиться на Pipeline A
- B: Переключиться на Pipeline B
Обработка аудиофайлов
Вы можете обработать музыкальные файлы цепочкой эффектов и сохранить результат в новых файлах.
- Область для перетаскивания или указания файлов:
- Специальная область для перетаскивания всегда видна под областью Effect Pipeline
- Поддерживается загрузка одного или нескольких аудиофайлов
- Файлы обрабатываются с использованием текущих настроек Pipeline
- Эффекты обрабатываются с частотой дискретизации Pipeline; преобразование частоты выходного файла выполняется после этого
- Статус обработки:
- Индикатор прогресса показывает текущий статус обработки
- Время обработки зависит от размера файла и сложности цепочки эффектов
- Параметры загрузки или сохранения:
- В разделе Настройки > Конфигурация > Вывод файлов в автономном режиме выберите WAV или FLAC, частоту дискретизации и качество. Для FLAC можно выбрать кодирование без потерь с разрядностью 16 или 24 бита. Начальное значение — WAV 96 кГц, PCM 24 бита
- У каждого формата своё ограничение числа каналов. Если файл превышает предел выбранного формата, EffeTune не сводит каналы автоматически, а останавливается и предлагает способ решения
- Для нескольких файлов перед началом обработки выберите папку; каждый файл сохраняется в неё сразу по завершении
- В старых браузерах без поддержки выбора папки несколько файлов упаковываются в ZIP-архив для скачивания
Обмен цепочками эффектов
Вы можете поделиться конфигурацией вашей цепочки эффектов с другими пользователями.
- После настройки желаемой цепочки эффектов нажмите кнопку Поделиться в правом верхнем углу области Effect Pipeline
- URL веб-приложения автоматически скопируется в буфер обмена
- Поделитесь скопированным URL с другими – они смогут воссоздать вашу цепочку эффектов, открыв его
- Общие ссылки сохраняют настройки эффектов, необходимые для воспроизведения цепочки; веб-приложение также восстанавливает ваше обычное рабочее состояние из хранилища браузера
- В версии настольного приложения экспортируйте настройки в файл
.effetune_presetиз меню Файл - Поделитесь экспортированным файлом
.effetune_preset. Файл.effetune_presetтакже можно загрузить, перетащив его в окно веб-приложения
Резервное копирование и восстановление сохранённых данных
Откройте Настройки > Резервная копия / Восстановление, чтобы перенести сохранённые пресеты цепочки, пресеты эффектов, импульсные характеристики и измерения между веб-приложением, настольным приложением и расширением браузера. В веб- и настольном приложении можно также включить именованные пресеты Visualizer. При выборе пресета автоматически выбираются используемые им данные измерений или импульсных характеристик.
Параметры Включить данные измерений и Включить импульсные характеристики включены по умолчанию, чтобы резервная копия была самодостаточной. Отключайте любой из них, только если в месте восстановления уже есть соответствующие файлы измерений или импульсных характеристик. Восстановленные импульсные характеристики добавляются в окно Библиотека импульсных характеристик EffeTune. Восстановление копии не меняет текущую цепочку, громкость, выбранный пресет, настройки устройств, музыкальную библиотеку и правила URL расширения. Каждый файл .effetune_backup может занимать до 256 МБ; при необходимости разделите большую резервную копию на несколько файлов. Если восстановление прервётся, уже восстановленные элементы сохранятся, и тот же файл можно безопасно восстановить повторно.
Прежде чем делиться резервной копией, проверьте выбранные элементы: она может содержать названия и комментарии пресетов, исходные файлы импульсных характеристик и сведения об измерениях. Музыкальные файлы, данные музыкальной библиотеки, настройки приложения, выбор устройств, правила URL, учётные данные и несохранённая текущая цепочка эффектов в неё не входят.
Настройки приложения
Откройте Настройки > Конфигурация…, чтобы выбрать Язык, задать Вид при запуске: (Effect Pipeline (по умолчанию), Музыкальная библиотека или Visualizer), настроить Конвейер эффектов при запуске: и выбрать Тема (Graphite, Paper, Midnight, Ember или Mint). Если для Вид при запуске: выбрано значение Музыкальная библиотека, можно также выбрать, какой раздел библиотеки открывается первым. В настольном приложении также можно выбрать Browser как вид при запуске.
В настройке Столбцы цепочки эффектов выберите Вручную, чтобы менять число столбцов кнопками +/−, или Автоматически (по умолчанию), чтобы столбцы вместе со списком эффектов помещались по ширине окна. В автоматическом режиме число столбцов меняется при изменении размера окна.
Версия из Microsoft Store получает обновления через Microsoft Store. В Настройки > Конфигурация… нажмите Открыть обновления Microsoft Store, чтобы проверить обновления, или Открыть настройки автозагрузки Windows, чтобы выбрать, запускать ли EffeTune автоматически. Настройки и данные входа в Browser этой версии хранятся отдельно от других настольных версий.
Измерение и коррекция частотной характеристики
Измерьте аудиосистему с помощью микрофона и создайте корректирующий EQ, который можно импортировать в EffeTune; подробнее см. Измерение и коррекция частотной характеристики и руководство по Pipeline Analyzer.
Сброс аудио
Если вы сталкиваетесь с проблемами аудио (прерывания, искажения):
- Выберите Сбросить аудио в меню Настройки или в дополнительном меню на мобильном устройстве. В настольном приложении также можно выбрать Перезагрузить в меню Вид
- Аудиотракт будет автоматически перестроен
- Конфигурация вашей цепочки эффектов сохранится
Удалённое управление OpenHome (настольное приложение)
Поддерживаемыми настольными версиями можно управлять из приложений OpenHome в той же локальной сети. По умолчанию эта функция отключена; настройка, сетевой доступ, совместимость и ограничения описаны в разделе Удалённое управление OpenHome.
Управление EffeTune через ИИ-ассистента (MCP)
Вы можете поручить Codex или Claude Code настройку MCP, а затем просить его добавлять эффекты, менять их параметры, загружать и сохранять пресеты в настольном приложении EffeTune. Используйте агента, который может выполнять команды на вашем компьютере.
- В настольном приложении EffeTune откройте Настройки > Дистанционное управление…, включите Разрешить дистанционное управление и нажмите Копировать ссылку.
- Отправьте агенту следующий запрос, подставив скопированную ссылку:
Настрой EffeTune MCP по официальному руководству:
https://github.com/Frieve-A/effetune/blob/main/mcp/README.md
Ссылка для подключения: <вставьте сюда скопированную ссылку>
После настройки перезапустите клиент, если агент попросит об этом, и попробуйте запрос: «Покажи мои текущие эффекты». Не публикуйте ссылку для подключения. Если вы нажмёте Новый токен или измените порт, повторите настройку с новой ссылкой.
Распространенные комбинации эффектов
Ниже приведены некоторые популярные комбинации эффектов для улучшения качества прослушивания:
Улучшение звучания на наушниках
- Stereo Blend -> RS Reverb
- Stereo Blend: Регулирует стерео ширину для комфортного прослушивания (60-100%)
- RS Reverb: Добавляет тонкую реверберацию помещения (микс 10-20%)
- Результат: Более естественное и менее утомительное прослушивание через наушники
Симуляция винила
- Wow Flutter -> Noise Blender -> Saturation
- Wow Flutter: Добавляет мягкие вариации высоты тона
- Noise Blender: Создает атмосферу, похожую на виниловую пластинку
- Saturation: Добавляет аналоговое тепло
- Результат: Аутентичное звучание виниловой пластинки
Стиль FM радио
- Multiband Compressor -> Stereo Blend
- Multiband Compressor: Создает характерное “радиозвучание”
- Stereo Blend: Регулирует стерео ширину для комфортного прослушивания (100-150%)
- Результат: Отполированное звучание в стиле FM-радио
Lo-Fi характер
- Bit Crusher -> Simple Jitter -> RS Reverb
- Bit Crusher: Уменьшает битовую глубину для ретро ощущения
- Simple Jitter: Добавляет цифровые несовершенства
- RS Reverb: Создает атмосферное пространство
- Результат: Классическая эстетика lo-fi
Устранение неполадок и FAQ
Если у вас возникли трудности, обратитесь к разделу Устранение неполадок и FAQ. Если проблема сохраняется, сообщите об этом через GitHub Issues.
Доступные эффекты
| Категория | Эффект | Описание | Документация |
|---|---|---|---|
| Analyzer | Analog Meter | Показывает уровни каналов на стрелочном индикаторе со шкалами VU, PPM, пика и loudness | Подробнее |
| Analyzer | Chroma Spiral | Показывает частотные составляющие по нотам и октавам на спирали | Подробнее |
| Analyzer | Level Meter | Показывает уровень аудио с удержанием пиков | Подробнее |
| Analyzer | Note Spectrogram | Показывает оцененные высоты звука во времени в виде piano roll | Подробнее |
| Analyzer | Oscilloscope | Визуализация формы сигнала в реальном времени | Подробнее |
| Analyzer | Pitch Meter | Отслеживает одну основную частоту и её настройку во времени | Подробнее |
| Analyzer | Rhythm Analyzer | Показывает темп, удары по долям и то, насколько каждая партия опережает долю или отстаёт от неё | Подробнее |
| Analyzer | Spectrogram | Показывает изменение спектра частот во времени | Подробнее |
| Analyzer | Spectrum Analyzer | В реальном времени показывает силу баса, середины и верхов | Подробнее |
| Analyzer | Stereo Meter | Визуализирует стереобаланс и корреляцию каналов | Подробнее |
| Basics | Bass Management | Направляет низкие частоты на один или несколько сабвуферов и суммирует LFE с басом основных каналов | Подробнее |
| Basics | Channel Divider | Делит стереосигнал на частотные полосы и направляет каждую полосу в отдельные стереопары выходов | Подробнее |
| Basics | DC Offset | Регулировка DC offset | Подробнее |
| Basics | FIR Crossover | FIR-кроссовер, направляющий круто разделённые частотные полосы на пары стереовыходов | Подробнее |
| Basics | Matrix | Гибко маршрутизирует и смешивает аудиоканалы | Подробнее |
| Basics | MultiChannel Panel | Панель управления несколькими каналами: громкость, mute, solo и задержка | Подробнее |
| Basics | Mute | Полностью отключает аудиосигнал | Подробнее |
| Basics | Polarity Inversion | Инвертирует полярность сигнала | Подробнее |
| Basics | Stereo Balance | Управление балансом стереоканалов | Подробнее |
| Basics | Volume | Базовое управление громкостью | Подробнее |
| Delay | Delay | Стандартный эффект задержки | Подробнее |
| Delay | Time Alignment | Точно настраивает время воспроизведения для согласования колонок и позиции слушателя | Подробнее |
| Dynamics | Attack Tonal Balance | Балансирует короткие атаки и устойчивую тональную структуру | Подробнее |
| Dynamics | Auto Leveler | Автоматически выравнивает громкость на основе измерения LUFS для стабильного прослушивания | Подробнее |
| Dynamics | Brickwall Limiter | Ограничивает пики сигнала, предотвращая цифровой клиппинг | Подробнее |
| Dynamics | Compressor | Сглаживает внезапно громкие места, делая прослушивание комфортнее | Подробнее |
| Dynamics | Expander | Возвращает динамический контраст, делая тихие звуки ниже порога еще тише | Подробнее |
| Dynamics | Gate | Уменьшает тихий звук в паузах и спокойных местах | Подробнее |
| Dynamics | Multiband Compressor | 5-полосное выравнивание громкости для ровного, похожего на радио звучания | Подробнее |
| Dynamics | Multiband Expander | 5-полосный экспандер для восстановления естественного контраста в слишком плоских записях | Подробнее |
| Dynamics | Multiband Transient | Настраивает атаку и сустейн отдельно в басе, середине и верхах | Подробнее |
| Dynamics | Power Amp Sag | Имитирует просадку напряжения усилителя мощности при высокой нагрузке | Подробнее |
| Dynamics | Transient Shaper | Настраивает ударность и тело музыки через атаку и сустейн | Подробнее |
| EQ | 15Band GEQ | 15-полосный графический эквалайзер | Подробнее |
| EQ | 15Band PEQ | 15-полосный параметрический эквалайзер для детальной настройки тембра при прослушивании | Подробнее |
| EQ | 5Band Dynamic EQ | 5-полосный динамический эквалайзер с регулировкой частот по порогу | Подробнее |
| EQ | 5Band FIR PEQ | 5-полосный параметрический эквалайзер с FIR-фильтрацией Minimum Phase или Linear Phase | Подробнее |
| EQ | 5Band PEQ | Гибкий 5-полосный эквалайзер для настройки баса, середины и верхов | Подробнее |
| EQ | Band Pass Filter | Выделяет определенный диапазон частот | Подробнее |
| EQ | Comb Filter | Добавляет фазовую, полую или металлическую окраску | Подробнее |
| EQ | Earphone Cable Sim | Помогает проверить, насколько малы обычные сдвиги АЧХ из-за кабеля наушников | Подробнее |
| EQ | Group Delay EQ | Регулирует задержку каждой полосы частот, не изменяя тембр | Подробнее |
| EQ | Group Delay PEQ | Параметрическое управление задержкой по частоте в пяти полосах, не изменяя тембр | Подробнее |
| EQ | Hi Pass Filter | Точно убирает нежелательные низкие частоты | Подробнее |
| EQ | Lo Pass Filter | Точно убирает нежелательные высокие частоты | Подробнее |
| EQ | Loudness Equalizer | Коррекция частотного баланса для тихого прослушивания | Подробнее |
| EQ | Narrow Range | Сочетание фильтров высоких и низких частот | Подробнее |
| EQ | Room EQ | FIR-коррекция по сохранённым измерениям помещения | Подробнее |
| EQ | Tilt EQ | Наклонный эквалайзер для быстрой коррекции тембра | Подробнее |
| EQ | Tonal Balance EQ | Автоматическая коррекция долговременного тонального баланса под целевой баланс музыкального стиля | Подробнее |
| EQ | Tone Control | Трехполосное управление тоном | Подробнее |
| Lo-Fi | AM Radio Simulator | Проводит музыку через модель тракта AM-передачи и приёма | Подробнее |
| Lo-Fi | Bit Crusher | Снижение битовой глубины и эффект zero-order hold | Подробнее |
| Lo-Fi | Cassette Artifacts | Записывает музыку на моделируемую компакт-кассету и воспроизводит её на деке Type I/II/IV с Dolby B/C | Подробнее |
| Lo-Fi | Digital Error Emulator | Имитирует разные ошибки передачи цифрового аудио и характер винтажной цифровой аппаратуры | Подробнее |
| Lo-Fi | DSD64 IMD Simulator | Имитирует слышимые интермодуляционные искажения от ультразвукового шума DSD64 | Подробнее |
| Lo-Fi | FM Radio Simulator | Пропускает музыку через физически смоделированный тракт FM-вещания и приёма | Подробнее |
| Lo-Fi | G.726 Simulator | Имитирует цикл кодирования и декодирования речи ITU-T G.726 с необязательной зашумлённой радиолинией | Подробнее |
| Lo-Fi | GSM-FR Simulator | Имитирует цикл кодирования и декодирования речи GSM-FR с битрейтом 13 кбит/с по радиолинии с маскированием потерь кадров | Подробнее |
| Lo-Fi | Hum Generator | Добавляет настраиваемый фон электрического гула 50/60 Hz для винтажного или lo-fi прослушивания | Подробнее |
| Lo-Fi | MD Simulator | Имитирует цикл кодирования и декодирования ATRAC эпохи MiniDisc | Подробнее |
| Lo-Fi | MP3 Codec Simulator | Имитирует чистый цикл кодирования и декодирования MPEG Layer III с низким битрейтом | Подробнее |
| Lo-Fi | Noise Blender | Добавляет регулируемую текстуру фонового шума для lo-fi атмосферы | Подробнее |
| Lo-Fi | SBC Codec Simulator | Воспроизводит цикл кодирования и декодирования Bluetooth A2DP SBC с необязательными потерями пакетов и маскированием | Подробнее |
| Lo-Fi | Simple Jitter | Имитация цифрового джиттера | Подробнее |
| Lo-Fi | SW Radio Simulator | Проводит музыку через модель тракта коротковолнового вещания, ионосферного распространения и приёма | Подробнее |
| Lo-Fi | Tape Artifacts | Записывает музыку на моделируемую катушечную ленту и воспроизводит её | Подробнее |
| Lo-Fi | TV Audio Simulator | Пропускает музыку через моделируемые тракты аналогового телевидения и NICAM | Подробнее |
| Lo-Fi | Vinyl Artifacts | Добавляет виниловые щелчки, треск, шипение, гул и утечку стереошума | Подробнее |
| Lo-Fi | Vinyl Simulator | Записывает вход в моделируемую канавку и воспроизводит ее физической моделью иглы | Подробнее |
| Modulation | Auto Filter | Перемещает резонансный фильтр с помощью LFO или огибающей громкости | Подробнее |
| Modulation | Auto Pan | Плавно перемещает уровень каждой стереопары в звуковом поле | Подробнее |
| Modulation | Chorus | Добавляет хорус, ансамбль, фленжер или вибрато движущимися задержками | Подробнее |
| Modulation | Doppler Distortion | Имитирует естественные динамические изменения звука от небольших движений диффузора динамика | Подробнее |
| Modulation | Frequency Shifter | Сдвигает частоты, выполняет кольцевую модуляцию или barber-pole-сдвиг | Подробнее |
| Modulation | Phaser | Создаёт движущиеся пики и провалы классической или barber-pole-развёрткой | Подробнее |
| Modulation | Pitch Shifter | Повышает или понижает высоту музыки без изменения темпа | Подробнее |
| Modulation | Pitch Shifter HQ | Повышает или понижает высоту с меньшим количеством фазовых артефактов | Подробнее |
| Modulation | Rotary Speaker | Объединяет независимое движение рупора и барабана для эффекта вращающегося динамика | Подробнее |
| Modulation | Tremolo | Эффект модуляции громкости | Подробнее |
| Modulation | Wow Flutter | Добавляет легкое дрожание высоты в стиле ленты или пластинки для винтажного характера | Подробнее |
| Resonator | Adaptive Prediction | Обучается предсказывать звук, выделять остаток и создавать развивающийся резонанс | Подробнее |
| Resonator | Horn Resonator | Симуляция резонанса рупора с настраиваемыми размерами | Подробнее |
| Resonator | Horn Resonator Plus | Более мягкий резонанс рупорной акустики для естественной окраски при прослушивании | Подробнее |
| Resonator | Modal Resonator | Частотный резонанс с поддержкой до 5 резонаторов | Подробнее |
| Restoration | Click Remover | Исправляет короткие щелчки, треск, хлопки и провалы | Подробнее |
| Restoration | Clip Restorer | Восстанавливает пики, сглаженные жёстким клиппированием | Подробнее |
| Restoration | Hum Remover | Удаляет постоянный электрический гул и его гармоники | Подробнее |
| Restoration | Noise Reduction | Уменьшает постоянный фоновый шум, сохраняя музыку | Подробнее |
| Reverb | Dattorro Plate Reverb | Классический plate reverb на основе алгоритма Dattorro | Подробнее |
| Reverb | FDN Reverb | Feedback Delay Network reverb с насыщенными плотными реверберационными текстурами | Подробнее |
| Reverb | IR Reverb | Свёрточная реверберация с импортированными импульсными характеристиками помещений и оборудования | Подробнее |
| Reverb | RS Reverb | Реверберация со случайным рассеянием и естественной диффузией | Подробнее |
| Saturation | Bandwidth Extender | Генерирует высокочастотный контент выше обнаруженной или заданной частоты среза | Подробнее |
| Saturation | Bass Extender | Генерирует бас на октаву ниже подходящего низкочастотного материала | Подробнее |
| Saturation | Dynamic Saturation | Имитирует нелинейное смещение диффузоров динамиков | Подробнее |
| Saturation | Exciter | Добавляет гармоники для ясности и присутствия | Подробнее |
| Saturation | Hard Clipping | Цифровой эффект жесткого клиппирования | Подробнее |
| Saturation | Harmonic Distortion | Добавляет характер с настраиваемыми гармоническими искажениями 2-5-го порядка | Подробнее |
| Saturation | Multiband Saturation | Отдельно добавляет теплоту или остроту в низах, середине и верхах | Подробнее |
| Saturation | Saturation | Добавляет теплую аналоговую насыщенность и характер | Подробнее |
| Saturation | Sub Synth | Подмешивает фильтрованный низкочастотный сигнал для усиления баса | Подробнее |
| Saturation | Tube Simulator | Моделирует ламповые линейные каскады и двухтактные либо однотактные триодные усилители мощности на 300B/2A3 | Подробнее |
| Spatial | Crossfeed Filter | Наушниковый crossfeed-фильтр для естественной стереокартины | Подробнее |
| Spatial | Crosstalk Cancellation | Использует измерения у ушей, чтобы уменьшить перекрёстные помехи между стереоколонками | Подробнее |
| Spatial | MS Matrix | Преобразует stereo и Mid/Side для настройки центра и пространства | Подробнее |
| Spatial | Multiband Balance | 5-полосное управление стереобалансом по частотам | Подробнее |
| Spatial | Phase Select EQ | Усиливает или ослабляет частотные компоненты, выбранные по разности фаз L/R и Balance | Подробнее |
| Spatial | Spatial Mapper | Разделяет звук на Direct, Diffuse и Residual для гибкой многоканальной маршрутизации | Подробнее |
| Spatial | Stereo Blend | Управляет шириной стерео: от стерео с инвертированной полярностью через моно до расширенного стерео | Подробнее |
| Others | Oscillator | Генератор тестовых тонов и шума для проверки колонок и наушников | Подробнее |
| Others | SFZ Note Player | Воспроизводит обнаруженные ноты импортированным инструментом SFZ | Подробнее |
| Control | Section | Группирует эффекты, чтобы всю секцию можно было обойти или вернуть в работу | Подробнее |
Техническая информация
Совместимость с браузерами
Frieve EffeTune был протестирован и подтвержден для работы в Google Chrome. Приложение требует современного браузера с поддержкой:
- Web Audio API
- Audio Worklet
- getUserMedia API
- Drag and Drop API
- Service Worker (для установки веб-приложения и запуска офлайн)
Поддержка браузеров
- Chrome/Chromium
- Полностью поддерживается и рекомендуется
- Обновите до последней версии для лучшей производительности
- Firefox/Safari
- Ограниченная поддержка
- Некоторые функции, такие как выбор выходного устройства, Wake Lock, установка приложения или поддерживаемые форматы аудио, могут различаться в зависимости от браузера
- Рекомендуется использовать Chrome для оптимального опыта
Рекомендуемая частота дискретизации
Установите для параметра Частота дискретизации в EffeTune значение 96 кГц. Это уменьшает слышимый алиасинг от нелинейных эффектов, например сатурации. Эта настройка задаёт внутреннюю частоту обработки EffeTune и работает независимо от частоты дискретизации ОС, аудиоинтерфейса или виртуального аудиоустройства. Проверьте фактическую частоту дискретизации, показанную в приложении: пока вы не сохраните настройку, может использоваться значение по умолчанию ОС или браузера, а веб-приложение может перейти на другую частоту, если 96 кГц недоступны. Если звук прерывается, сначала отключите требовательные эффекты или сократите цепочку и лишь при необходимости понизьте частоту дискретизации.
Руководство по разработке
Хотите создать собственные аудиоплагины? Ознакомьтесь с нашим руководством по разработке плагинов.
Библиотека DSP
DSP-движок EffeTune также доступен как самостоятельная детерминированная библиотека под лицензией MIT для Python, JavaScript и браузерных AudioWorklet. Её публичную схему Chain и автоматически сгенерированный каталог эффектов можно использовать без приложения EffeTune. Подробнее см. документацию EffeTune DSP Library.
Инструкции по установке и полные готовые к запуску примеры приведены в кратких руководствах для пакетов:
Эффекты, схемы, особенности обработки и необходимые ресурсы описаны в руководстве по DSP Library.
