文档

Visualizer

Visualizer 将 EffeTune 处理后的音频转换为可自定义的视觉画面,可将波形、频谱、滚动声谱图、立体声声像或音符声谱图与专辑封面、视频画面和曲目信息一同展示。调整显示画面不会改变声音。

打开与显示

在桌面端布局中,点击 Effect Pipeline 和 音乐库 旁边的 Visualizer;在移动端,点击右上角的 Visualizer 图标;在桌面应用中,选择 视图 > Visualizer;在浏览器扩展中,点击 Pipeline Editor 顶部的 Visualizer。也可在 设置 > 配置… 中将 Visualizer 设为启动视图。 选择 Visualizer 后,启用启动时铺满应用窗口,下次启动时 Visualizer 就会占满应用的显示区域。

可先从内置预设开始体验。预设按 16:9、21:9、4:3、1:1 和 9:16 画面比例分组,与当前应用窗口宽高比越接近的分组越靠前。选择预设会替换当前布局。图表显示的是经过所有已启用效果处理后、即将送往输出的音频信号。

每种画面比例都提供 11 种通用预设:

  • Mastering Console:在深色面板上排列左右声道叠加频谱、声谱图、立体声显示、响度表和分段式电平表。
  • Spectral Studio:大尺寸高分辨率声谱图搭配竖向柱状频谱。
  • Harmony Lab:以钢琴卷帘视图显示检测到的音符,并用色度螺旋展示音高类别分布。
  • Phosphor Scope:以模拟 CRT 荧光屏的绿色辉光绘制示波器和立体声显示。
  • Hi-Fi Deck:仿照经典音响荧光显示屏风格的分段式频谱与电平显示。
  • Vintage VU:嵌在胡桃木边框中、带背光奶油色表盘的左右声道 VU 表。
  • Now Playing:在模糊封面背景上显示专辑封面、曲目信息和频谱柱。
  • Neon Pulse:带倒影的霓虹柱状频谱,背景随低音律动。
  • Phase Galaxy:将相位图渲染为闪耀旋转的星体。
  • Chroma Mandala:将色度螺旋渲染为万花筒图案。
  • Groove Lounge:将专辑封面和曲目信息与识别出的和弦、调性及随演奏亮起的架子鼓组合显示。整体采用沉稳的青绿色与金色,并配有简洁的频谱、播放按钮、进度条和已播放时间。

另有 10 种预设仅在最适合的画面比例下提供:

  • Fretboard(21:9、9:16):在吉他指板上显示检测到的音符并附带节拍指示;21:9 布局还在指板上方增加了钢琴卷帘视图。
  • Power Amp(21:9、16:9):黑色功放前面板上的蓝色背光 VU 表。
  • Round Dials(1:1、9:16):镶有黄铜外圈的圆形 VU 表。
  • Beat Stage(16:9、9:16):在随低音律动的大节拍圆环内显示检测到的速度,并搭配霓虹频谱柱。
  • Lyric Stage(16:9、9:16):在随低音律动的专辑封面柔光之上显示同步歌词,并逐词高亮当前行(无歌词曲目则显示静态封面画面)。
  • Cinema Strip(21:9):横跨整屏宽度的声谱图、10 秒波形与横向滚动歌词。
  • Meter Bridge(21:9、4:3):将 True Peak、VU、慢速 RMS 和响度表并排排列在电平表与波形条上方,便于对比同一段音乐在不同表头下的响应。
  • Counter Gallery(16:9):同屏展示八个实时计数器,涵盖机械式、LED、VFD、LCD、点阵、翻页和辉光管风格,包括按 30 fps 计算的帧显示。可比较它们的动作、欣赏显示效果,或单独复制某个 Counter 到自己的布局。
  • Listening Room(16:9):以大幅专辑封面和曲目信息为主,搭配播放按钮、进度条、已播放时间及低调的频谱条,在石墨色背景上点缀温暖色调。
  • MIDI Monitor (21:9, 9:16): 面向日常 MIDI 欣赏,将16通道 MIDI 混音器和事件列表与曲目信息、播放控件、已播放时间及进度条组合在一起。21:9 布局还提供单行歌词。

将指针移到画面上或点按画面会显示 ⛶,点击即可在保持所选比例的同时铺满应用窗口(边缘可能被裁切)。再次点击 ⛶、按 Esc 或使用移动端返回操作即可恢复。在桌面应用中,若在打开 Visualizer 时切换到迷你播放器,可视化画面会显示在播放控件上方。

在连接两台及以上显示器的桌面应用中,选择 视图 > Visualizer 纯净输出 可在指定显示器上无边框、无控件全屏显示 Visualizer。布局保持原有比例,余留空间以黑边填充。纯净输出启用期间,应用内的 Visualizer 预览会按输出显示器的分辨率渲染以保持一致。当切换到其他应用(除非在同一菜单中启用了 非活动时也显示)、主窗口与该显示器重叠或正在进行双盲测试时,纯净输出会自动隐藏。若要停止,请选择 关闭,或点击输出画面后按 Esc。仅有一台显示器时,此菜单项不可用。

MIDI 显示

MIDI 添加了类似 SoundFont Player 中 MIDI Mixer 的分通道显示。它显示每个通道的音色、发音键盘、电平、Volume、Pan、Expression、Reverb、Chorus、Mute 和 Solo。SoundFont Player 运行时,还会显示音色名称、发音数、控制状态和实测通道电平。没有 SoundFont 时,键盘仍会显示按住的 MIDI 音符,控制值来自 MIDI 文件或连接的设备;实测电平和 Mute/Solo 则不可用。此项目仅供查看;请在 SoundFont Player 中调整播放。

音色名称取自效果列表中第一个已启用的 SoundFont Player;如果它不可用,显示不会改用后面的播放器。键盘按白键和黑键的形状绘制,五项控制值以旋钮显示。静音与独奏默认隐藏。

用起始通道和结束通道缩减行数。按空间大小显示或隐藏音色、发声音符、电平、控制器、静音与独奏和发音数;静音与独奏默认隐藏。数值可将数字放在旋钮右侧(默认)或下方,选无(仅旋钮)可隐藏数字。调整旋钮大小(50%~150%,默认100%)和旋钮样式:填充(默认)或轮廓。旋钮填充色、旋钮轮廓色和旋钮指针色分别设置本体、边框和指针颜色;填充色仅用于填充样式。

MIDI 变化时闪烁默认开启,MIDI改变音色或旋钮数值时会短暂高亮,然后渐渐淡出。通过闪烁颜色选择颜色。键盘颜色提供普通、通道和音符颜色;普通模式的高亮键颜色由发音键颜色设置。用字体和文字大小调整文字。项目调色板用于整张表格的文字,默认白色。加宽项目即可看清所有列。

在电平表中,可使用与 Level Meter 相同的刻度、方向、分段、衰减时间、峰值、坐标轴、数值和调色板设置来调整通道电平表。默认横向显示,范围为−48 dB,不显示坐标轴和数值。电平表调色板与文字颜色独立。

MIDI Event List 显示当前 MIDI 文件中的全部事件,包括音符、控制器、音色切换、速度、拍号和歌词。Channel、Bar:Beat:Tick、Type 和 Contents 列分别展示事件的位置及内容。当前播放位置保持在中央;已发生的事件在上方,即将发生的事件在下方。列表会随播放、暂停和跳转位置更新。单独的实时 MIDI 输入没有可供显示的曲目时间轴。

可通过 字体(默认为 Monospace)、文字大小(8–32 px,默认 14 px)和 行间距(100–300%,默认 150%)调整表格的可读性。加宽项目可为 Contents 留出更多空间。 滚动方式可选每次移动一行的逐行(默认)或连续移动的平滑。项目调色板用于全部文字,默认白色。

Notes、Drums、Guitar 和 Rhythm Analyzer 提供 优先使用 MIDI,默认开启并随布局保存。播放 MIDI 曲目时使用文件中的音符和节拍信息,即使处于休止段或未加载音源也保持 MIDI 显示。关闭后恢复常规音频分析。其他音频分析项目仍按原方式显示音频。

Notes 显示非鼓音符,包括延音踏板和弯音;亮度代表 MIDI 力度,而不是测得的音频电平。Guitar 根据所选调弦、变调夹和品位范围分配音高。指法与和弦名称属于推断,并非原始演奏指令。Drums 使用打击乐通道的标准 GM 打击乐映射,也包括由 GS/XG 消息指定的通道;自定义鼓组可能不同。Rhythm Analyzer 的速度、节拍指示灯和节拍网格遵循文件中的时间信息,并反映播放速度。起音和鼓声检测以及 Beat lens 仍使用音频分析。

编辑布局

选择 Edit 可自定义布局。修改会立即生效,并在下次打开 EffeTune 时自动恢复。仅编辑布局不会覆盖已保存的预设;如需保存为命名预设,请使用预设对话框中的 保存。

在编辑模式下,左侧面板包含整体场景设置、项目列表和 画质,中间是画布,右侧是所选项目的控制项。数值参数可通过滑块调节,也可直接输入数值。

使用画布工具栏中的 − 和 +,或按住 Ctrl+滚轮(Mac 上为 Cmd+滚轮)以指针为中心缩放(10–400%),便于精细排版;点击 适应窗口 可将整个画框居中显示。使用鼠标滚轮或触控板可平移画布(按住 Shift 可水平滚动),也可按住鼠标中键或 Space+左键拖动 平移。当画布获得焦点时,按 + 和 − 以中心缩放,按 0 适应画框。平移和缩放不会计入 撤销 步数。

将项目移出或放大到画框外时,无论在编辑模式还是正常视图下都会沿画框边缘裁切,同时编辑区域仍会保留其选择手柄。例如,可将 Shape 部分放在画框外,制作与显示边缘齐平的面板。

  • 选择画面比例、背景颜色或背景图片(大图会自动缩放)。主题颜色 可自定义当前布局的图表基底色、浅色图表填充、细网格与主网格、图表标签、坐标轴标题和仪表刻度,而不改变波形与曲线的调色板。未修改的颜色始终使用默认深色主题配色,不受 EffeTune 界面主题影响。点击 使用默认颜色 可恢复默认配色。
  • 图形缩放(×0.50 至 ×3.00,默认 ×1.00):图表会从小窗口到 4K 等比例缩放。图形缩放 会统一放大或缩小布局中所有图表的线条、刻度、峰值标记和图表标签,而 Title、Album、Artist 和 Text 则保持各自的字号。
  • 可添加 Oscilloscope、Spectrum、Spectrogram、Stereo、Level Meter、Analog Meter、Notes、MIDI、MIDI Event List、Drums、Guitar、Chroma Spiral、Phase Map 或 Rhythm Analyzer 图表,也可添加 Lyrics、Artwork、Video、Title、Album、Artist、曲目信息、Playback Control、Seek Bar、Counter、Key、Chord、Text 或 Shape。拖动项目可移动位置,拖动控制点可调整大小(按住 Shift 保持宽高比,按住 Ctrl/Cmd 从中心缩放)。使用 吸附到网格 可辅助对齐,拖动时按住 Alt 可暂时忽略吸附。上移、下移、移到最顶层 和 移到最底层 控制图层前后顺序(列表中越靠下的项目显示越靠前)。按 Ctrl+D(Mac 上为 Cmd+D)或按住 Alt 拖动 可复制所选项目。
  • 在画布或列表中按住 Shift+单击(或在列表中 Ctrl/Cmd+单击)可选择多个项目,也可在空白画布上拖出选框(Shift+拖动 可追加选择)。在项目重叠处按 Ctrl+单击(Mac 上为 Cmd+单击)可依次循环选择指针下方的后层项目。按 Ctrl+A(Cmd+A)全选,按 Esc 取消选择。移动、删除、复制副本、剪切、复制和粘贴均会作用于所有选中项目。当所选项目属于同一类型时,右侧面板中的修改会同时应用到全部选中项目,并提供边缘与居中对齐按钮。
  • 撤销 和 重做(Ctrl+Z / Ctrl+Y;Mac 上为 Cmd)可在当前会话中逐步回退或恢复布局修改、预设加载和链接导入。剪切项目、复制项目 和 粘贴项目(Ctrl+X、Ctrl+C、Ctrl+V)通过剪贴板移动项目,其中 粘贴项目 还支持直接导入剪贴板中的 Visualizer 分享链接。按 Delete 删除所选项目。在画布上右键单击(或长按)即可快速打开这些命令。
  • 每个图表默认显示输出通道 1–2。选择单个通道时会在整个图表中显示该通道(在 Level Meter 和 Analog Meter 中则显示为单根电平条或单个表头)。水平轴与垂直轴均可翻转。
  • 颜色模式:纯色 使用单一颜色选择器;渐变 提供可编辑色标及 24 种预设(选择预设后点击 应用)。反转渐变 会翻转色标顺序。Hue 随时间循环变换色相,Scroll 让渐变流动,两者均支持调节 速度 与 反转颜色变化方向。

对于 Title、Album 和 Artist,可分别设置字体、字号、水平/垂直对齐、字间距、大小写、加粗、斜体、描边 和 阴影。Artwork 和 Video 支持 圆角。

添加曲目信息,可以显示当前文件或网络曲目中可用的标签和音频格式。使用 AirPlay 时,还会显示发送端提供的设备信息、接收编解码器、接收端 PCM 格式和发送端音量。未提供的项目不会显示。文字样式使用与 Title 相同的设置。Title、Artist、Album 和 Artwork 也会显示 AirPlay 发送端提供的信息。

添加 Text 可显示静态标签或聆听空间名称(最多 4096 个字符,支持多行),并提供与 Title 相同的排版、描边和阴影控件。

添加 Playback Control,即可在布局中放置播放器按钮。通过操作选择播放 / 暂停、停止、上一曲、下一曲、随机播放或重复播放;每个按钮使用一个独立项目。在 Edit 之外,单击或点按按钮即可操作,也可用 Tab 聚焦后按 Enter 或 Space。播放器打开时,无法使用的按钮会淡化显示。单曲重复时不能使用随机播放。

  • 外观提供简约、玻璃和浮雕作为调整的起点,不会改变操作或位置。按钮形状可选圆角矩形或椭圆;将椭圆的宽高设为相同值即可得到圆形。填充颜色和填充不透明度调整背景,边框颜色和边框宽度调整外框(宽度为 0 时隐藏边框),圆角半径调整矩形的圆角。增大表面立体感可加强明暗层次,设为 0 则呈现平面效果。
  • 显示内容可选图标、图标和标签或标签。图标大小调整符号的尺寸;将自定义标签留空可自动显示操作名称。显示标签时,也可使用常规文字样式。调色板控制图标和标签的颜色;启用时的颜色突出显示已开启的随机播放和重复播放。还可结合现有项目效果,让按钮与布局风格一致。

添加 Seek Bar,即可放置水平播放进度条。在 Edit 之外,单击或拖动选择位置,松开后跳转。也可用 Tab 聚焦后,使用方向键、Home 或 End 操作。当前曲目无法跳转时,进度条会淡化显示。

  • 外观提供纤细、经典和粗壮作为调整的起点。轨道颜色、轨道不透明度和轨道粗细调整背景条;圆角端点让两端变圆。调色板控制已播放部分的颜色。显示滑块控制播放位置标记的显示与隐藏,滑块大小和滑块颜色调整其外观。滑块形状可选圆形、正方形、菱形或竖条。滑块边框宽度和滑块边框颜色控制轮廓;宽度设为 0 可隐藏边框。也可使用现有项目效果。

播放器暂停或停止时,Playback Control 和 Seek Bar 仍会显示。未打开播放器时,两者在 Edit 之外均会隐藏,Clean Feed 中也一样;仍可在编辑器中配置它们。

添加 Counter 可显示内置播放器的当前播放位置,并随暂停和跳转更新。使用外部输入时,它从添加 Counter 或在当前会话中载入布局的时刻开始计时,隐藏 Visualizer 后仍会继续。在 Edit 之外点击或轻触计数器,只会将该 Counter 的外部输入计时归零,不会改变播放器的播放状态。

接收 AirPlay 时,如果发送端报告了曲目播放位置,Counter 和 Seek Bar 就会显示该位置,并随发送端的报告更新。无法拖动跳转,也无法使用不受支持的播放操作。选择停止可结束当前接收。设置方法和音频格式说明请参阅网络音乐指南。

  • 播放列表序号、小时、分钟、秒和亚秒可分别显示或隐藏。默认显示 hh:mm:ss.mmm,不显示序号。播放器的播放列表序号从 1 开始,外部输入显示 00。显示的最高整数时间单位会累计:隐藏小时后显示总分钟数;同时隐藏小时和分钟后显示总秒数。
  • 小数位数(1–4,默认 3)设置秒的小数位数,3 位表示毫秒。分隔符 › 时间(:)、亚秒(.)和编号(一个空格)各可输入最多 8 个字符,也可留空。
  • 亚秒格式可选择小数或帧。小数位数仅用于小数模式。帧数按播放时间和所选帧率(1–120,默认 30)计算,从 0 数到比帧率小 1 的数值。需要时请设为与视频一致的帧率;此显示并非精确读取文件中的实际帧。
  • 字体提供数字专用的七段数码管、点阵和线形数字,均已内置,可离线使用,也可搭配颜色设置和 Glow 效果。
  • 切换 › 样式可选择无(默认)、滚动、翻页或交叉淡化。滚动会让最低位时间数字连续转动,较高位随进位移动。翻页会翻转上下分开的显示板,交叉淡化则渐变叠合新旧数字。时长(0–1000 ms,默认 150 ms)用于翻页和交叉淡化。
  • 最少位数(1–8,默认 2)设置所显示的最高整数时间单位的最少位数。前导零默认开启,关闭后用空格代替零。超过设定位数的数值仍会完整显示。
  • 背景 › 图案可选择无、完整图案(全部七段或整个点阵,其他字体则显示 8)或所有数字(叠加 0–9)。不透明度和颜色控制当前数字背后的暗淡图案。完整图案可模拟未亮起的数码管段或点阵,所有数字可模拟辉光管。
  • 数字窗口 › 显示为每个数字添加窗口,可调整边框颜色、边框宽度、填充颜色、填充不透明度和圆角半径,并用内侧阴影增加纵深感。翻页模式自带中央接缝和阴影。
  • 预设提供机械式、红色LED、蓝绿色VFD、经典LCD、点阵、翻页和辉光管,可选用后继续调整。时间字段、分隔符、精度、最少位数、前导零、位置和大小均保持不变。若想营造磁带机的外观,可隐藏亚秒并选择机械式。

添加 Lyrics 可显示内置播放器当前曲目的同步或纯文本歌词(在纯净输出中同样可见)。歌词会自动从音频内嵌标签或同文件夹下的同名 .lrc 文件读取(对于 CUE 分轨曲目,Artist - Title.lrc 或 Title.lrc 优先于整张专辑的同步歌词)。对于直接在浏览器中打开或拖入的音乐,请将 .lrc 文件与音乐一起选择或拖入;流媒体没有歌词。在未打开 Edit 时,点击或点按带时间轴的歌词行即可跳转到对应播放位置。

MIDI 文件可以显示内嵌歌词,也可以显示同名 .wrd 文件中的文字。.wrd 有可读内容时优先使用它。桌面应用会读取 MIDI 旁边的文件;在浏览器中,请将两个文件一起选择或拖入,或者从已授权的 Music Library 文件夹播放 MIDI。WRD 文字会以整页显示,并随音乐切换;视图、滚动和单词高亮不适用于这些页面。如果没有可读的 WRD 文字,会依次使用 MIDI 内嵌的 Lyric 事件、.kar 文件或标有 @KMIDI 的 MIDI 文件中的卡拉 OK 文本,最后才使用同名 .lrc 文件。卡拉 OK 的标题信息和和弦标记不会显示为歌词。MusicXML 歌词仍使用通常的逐行和逐词显示设置。需要选择歌词时可指定声部和段落,否则保持自动。

  • 可选择 列表 或 单行(单行可开启 显示下一行)。列表视图支持 滚动(纵向)、逐行(纵向)、滚动(横向) 和 逐行(横向),并可调节 逐行过渡时间(0–2 秒,默认 0.18 秒)和 当前行位置(0–100%,默认 50%)。当歌词包含逐词时间信息时,单词高亮 会渐进填充当前行;偏移(−10 至 +10 秒)用于微调同步时间,正值会让歌词延后显示。没有时间信息的歌词始终以列表显示,随播放进度滚动,不做高亮。
  • 行距(50–300%,默认 100%)用于调整行与行之间的间距。淡入时间(0–10 秒,默认 1 秒)和 淡出时间(0–10 秒,默认 3 秒)让 Lyrics 项目在每首曲目的开头和结尾平滑淡入淡出;设为 0 即关闭对应的淡变。

添加 Video 可显示内置播放器正在播放的视频画面(支持浏览器或操作系统可解码的 MP4、M4V、MOV、MKV、WebM、3GP)。适应方式 可选 完整显示(默认)、填满并裁剪 或 拉伸。无视频时显示封面(默认开启)会在播放纯音频曲目时回退显示专辑封面。通过 CUE 索引文件播放的曲目不显示视频。

添加 Shape(矩形、椭圆、三角形 或水平 直线)可创建面板、边框或分隔线,支持调节 填充不透明度、边框颜色、边框粗细、边框不透明度 和 圆角半径。将 椭圆 的宽和高设为相同即为圆形,将 填充不透明度 设为 0% 只保留边框,将 边框粗细 设为 0 则去掉边框。

调整和阅读图表

Spectrum 按频率显示电平并带有回落峰值标记。方向 可在 水平(默认)与 垂直 之间切换。显示方式 可选 线条 或 柱状。在 柱状 下,频段数(8–128,默认 48)设置柱子数量,每格 dB(0.5–12 dB,默认 1 dB,设为 0 即 连续)设置每格的大小(越小台阶越细),量化(默认开启)会将柱子和峰值对齐到整格,但不改变测得的电平。采样点数 是分析长度:点数越多,越能分开相邻的频率,但响应也越慢。频率刻度 可选 对数(HQ)(默认)、对数 或 线性,最高频率 设置频率上限(1–40 kHz,默认 40 kHz)。平滑 可在最宽 1 个倍频程内让曲线更平缓(默认 0),dB 范围 设置显示的最低电平(默认 −96 dB;负值越大,越能看到更弱的成分)。键盘 可添加钢琴琴键参考,键盘长度 设置琴键长度(默认 100% 为真实钢琴琴键的一半,200% 与真实钢琴一致)。键盘、坐标轴与网格 和 坐标轴标签与数值 默认关闭。

Spectrogram 将频率纵向排列并随时间横向滚动,使用与 Spectrum 相同的 采样点数(默认 4096)、频率刻度(默认 对数(HQ))、dB 范围、最高频率、键盘 和坐标轴控件。

Stereo 以菱形上的圆点显示立体声声像(两个声道共有的声音沿纵向分布,左右声道的差异沿横向分布),并带有峰值轮廓。峰值、相关性 和 平衡(均默认开启)分别控制峰值轮廓、相关性条(左右声道一致时为 +1,极性相反时为 −1)和平衡条(以 dB 显示哪一侧更响)的显示。窗口(10–1000 ms,默认 100 ms)设置显示的最近音频长度:越短越能跟上瞬态,越长显示越稳定。

Level Meter 以水平或垂直方向显示各声道电平(默认 −48 至 0 dB,dB 范围 可调 −144 至 −48 dB),支持连续或分段条形(每格 dB)、峰值保持标记以及持续 5 秒的 OVERLOAD 削波警告。坐标轴与网格、坐标轴标签与数值 和 电平数值(保持的峰值读数;关闭 峰值 时为当前电平)用于切换刻度与数字读数,三者默认均关闭,而 OVERLOAD 始终显示。支持 纯色、渐变 和 热力图 颜色模式。

Oscilloscope 在 显示时长(1–10000 ms,默认 10 ms)范围内绘制波形振幅。较短时间绘制线条轨迹,较长时间绘制最小值/最大值包络带。触发模式 可选 自动(默认;没有触发也持续更新)、正常(保持上一条波形,直到信号沿 触发沿 方向穿过 触发电平)或 关闭(连续滚动波形;忽略触发设置)。触发电平(−1 至 1,默认 0)、触发沿(上升沿(默认)/ 下降沿)和 触发保持时间(0.1–10 ms,默认 0.1 ms;越长越能抑制短间隔的重复触发)决定捕获位置。显示电平(−96 至 0 dB,默认 0 dB)越低,较弱的波形显示得越大;垂直偏移(−1 至 1,默认 0)为正值时波形上移。

Notes 以 水平 或 垂直 布局在 1–10 秒的 显示时长 内显示检测到的音高,支持设置 音高分辨率(1/12 八度 或 高精度)、音量(默认开启;以条的粗细显示各音的相对音量)、最低音 / 最高音,以及可选的 键盘 和坐标轴。

要在 Notes 中显示和弦轨道与 Key,请开启 Chords & Key(默认关闭)。Key 显示当前片段的估计调性,无法识别调性时不显示。音名与和弦名称根据当前局部调性使用 # 或 ♭。显示内容的读法请参阅 Note Spectrogram。

添加 Key 或 Chord,即可将调性和和弦名称作为独立文本显示,无需放置 Notes。Key 显示当前片段的估计调性(例如 F major);Chord 显示最近确认的和弦名称(例如 B♭/D),音名写法依据当前局部调性。尚无结果的项目会保持空白。您可以选择声道,并使用与 Title 相同的字体、大小、对齐、描边、阴影和颜色设置。 选择 音符颜色 时,Key 按调性的主音着色,Chord 按和弦的根音着色,配色与 Note Spectrogram 相同。

Guitar 将检测到的音高映射到指板上。可选择预设的吉他、贝斯或尤克里里 调弦,或输入自定义 空弦音(最多 10 根弦),并设置 最低品位、最高品位 和 变调夹。把位显示 可选 全部把位(所有对应的品位)、单一指型(每个音只取一个可弹的位置:各音分在不同的弦上,手指跨度小,并靠近前一个手位)或 单一指型+其他候选(其他位置以淡色显示)。和弦 会根据所选的调弦、变调夹和品位范围,显示检测到的和弦的建议指型。指型会跟随最新确认的和弦变化,未检测到和弦时会消失。标签 可选 无、音名 (♯)、音名 (♭)、音名(检测到的音阶)(根据检测到的调性使用 # 或 ♭)或相对 根音 的 音程;根音 设为 自动 (最低音) 时跟随检测到的最低音,选择固定音时可叠加 音阶指引。检测阈值(10–90%,默认 50%)设置音符显示所需的强度,若杂音闪烁可调高。按音量调整圆点大小 会让越响的音画得越大(最弱的音为三分之一大小)。还可调节 衰减时间(0–2 秒)、布局(水平六线谱或垂直和弦图)、无品(连续音高定位,直观呈现推弦、揉弦和滑音)、真实品丝间距、指板填充、品位标记、品位编号、弦名 和 水平翻转。

Drums 显示一套 3D 架子鼓,检测到 Kick、Snare、Hi-hat、Tom 或 Cymbals 的敲击时,相应乐器就会发光,让你在听音乐的同时直观地跟随鼓点。识别可能漏掉鼓点,也可能将其他声音误判为鼓声。通鼓尤其容易误检,因此其发光仅供参考。Rhythm Analyzer 仍只显示通鼓以外的四种乐器。

  • 水平视角(−180° 至 180°)改变环绕架子鼓的观看方向。调高 俯视角度(5°–80°),就能从更高的位置看清鼓面。
  • 鼓腔颜色、镲片颜色、金属部件颜色 和 鼓面颜色 分别设置各部分的颜色。调色板 中的 颜色 设置鼓点的发光颜色;Drums 仅使用 纯色。建议先选用与鼓身颜色反差明显的发光颜色,让鼓点更容易辨认。

Chroma Spiral 以 Dots 或 Fill 模式将检测到的音高排列在八度螺旋上,支持调节 最低八度、最高八度、频率倾斜、电平范围 和 显示下限。

Phase Map 与 Phase Select EQ 视图一致,纵向绘制频率成分,横向在 X 轴 上显示左右声道 相位(中心 0°,两端 ±180°)或 平衡;点越亮、越大,成分越强。dB 范围(−96 至 −24 dB,默认 −72 dB)设置从最强成分往下显示的范围(负值越大,越能看到更弱的成分)。基准电平下限(−120 至 −24 dB,默认 −40 dB)设置基准电平的下限,当最强成分也低于此值时,点会变小变淡。余辉时长(0.1–2.0 秒,默认 0.5 秒)越长,留下的轨迹越浓。坐标轴默认关闭。

Analog Meter 提供 VU(默认)、PPM、RMS、Sample Peak、True Peak、Loudness 或 Custom 模式的经典指针表头,采用与 Analog Meter 效果器相同的阻尼响应与刻度控制,并且只显示所选模式用到的控件。Custom 会增加 检波器、指针响应时间、过冲 和 刻度,用于选择测量方式、指针速度、指针过冲幅度和刻度;不适用于所选检波器或刻度的控件会保留在原位但不可用。在 Loudness 模式下,通道表头之前会先显示一个节目响度表,显示 Momentary、Short-term、Integrated、LRA 和最大 True Peak;关闭或隐藏 Visualizer,或更改通道、模式 或 指针 时,Integrated、LRA 和最大 True Peak 会重新开始计算。除测量参数外,还可通过外观控件打造平面功放表头或复古圆形表盘:

  • 刻度形状:刻度曲率(0% 直线至 100% 圆弧)、刻度展开角度(30°–160°,默认 100°)和 下移指针轴心(0–100%)。
  • 指针外观:隐藏指针根部(0–90%)、指针长度(50–120%,默认 102%)、指针宽度(0.5–8)、指针尖端形状(线形、渐尖 或 箭头,其中 箭头 支持 0.25–4.00 的 箭头尖端长宽比)以及 轴心圆点大小(0–20)。
  • 表盘文字:VU 模式下的 辅助百分比刻度 与 读数单位(100% 为所选 参考电平 下的 0 VU;百分比是电压比,因此 50% 约为 −6 VU),以及 数值读数、通道标题、模式标题、− / + 标记、正刻度显示+号 和 红色区域 开关。
  • 仪表表盘:窗口形状(矩形、椭圆、圆形)、表盘颜色、表盘不透明度、表盘边框颜色、表盘边框宽度 和 暗角(0–100%)。

Rhythm Analyzer 使用与 Rhythm Analyzer 效果器相同的分析引擎显示速度、逐拍起音时机和频段微时序;此处不提供 Metronome Click。最低 BPM(40–192,默认 40)和 最高 BPM(50–240,默认 240)设置速度搜索范围,更改任一项都会重新开始分析。跨度(拍)(4、6、8、12 或 16;默认 8)设置 计时轨道 和 回声行 每一行包含的拍数。速度图、计时轨道、回声行 和 节拍透镜 开关分别控制各面板的显示(默认开启 计时轨道 和 节拍透镜);项目较高时面板纵向堆叠,项目较宽时 节拍透镜 位于 计时轨道 旁边。此外,Visualizer 还提供位于中央的 节拍 闪烁圆圈和 BPM 文字叠加层,即使关闭全部四个图表面板也可独立工作。BPM 和节拍透镜显示的是已确定的分析结果,比声音晚约 1–2 秒;BPM 文字使用与 Title 相同的文字设置。 显示可在频段(默认)和鼓声之间切换,不会重新开始节奏速度分析。鼓声在三个鼓点面板中显示 Kick、Snare、Hi-hat 和 Cymbals,不显示通鼓。尚未确定拍内位置时,识别到的鼓点仍然可见。识别可能漏掉鼓点,也可能把其他声音当成鼓声。

  • 节拍圆圈:可调节 圆圈大小(10–100%,默认 90%)、边框宽度(0–20,默认 2;设为 0 隐藏边框)、填充不透明度(默认 30%)、边框不透明度(默认 100%)、使用调色板颜色(或自定义 填充颜色 / 边框颜色)、将 BPM 缩放至圆圈内(缩小居中的 BPM 文字,使其容纳在圆圈内)、保持亮起时间(0–1000 ms,默认 0 ms;最亮状态在开始衰减前保持的时间)和 衰减时间(10–2000 ms,默认 90 ms)。沿圆周移动的圆点默认开启;无论使用音频分析还是 MIDI 节拍,圆点每拍绕圆圈一周。

对于 Spectrum、Spectrogram 和 Stereo,输入增益(−24 至 +24 dB)仅缩放图表显示幅度,不影响音频播放。Spectrum、Level Meter 和 Chroma Spiral 提供 衰减时间(每 20 dB 0–5 秒);Spectrum、Level Meter 和 Stereo 提供 峰值、峰值保持(0–10 秒)和 峰值衰减时间(每 20 dB 0.1–10 秒;Stereo 为 1–10 秒)。

在 颜色模式 下,Spectrum 和 Chroma Spiral 还支持固定的 音符颜色 与 热力图;Spectrogram、Level Meter 和 Phase Map 支持 热力图;Notes、Guitar、Key 和 Chord 支持 音符颜色;除 Drums 外,其他有颜色设置的项目只提供 纯色 和 渐变。在 渐变 模式下,Spectrum、Spectrogram、Notes、Guitar、Chroma Spiral 和 Phase Map 提供 渐变方向(频率、强度(按信号由弱到强分配颜色)或 径向);其他项目提供 直线 与 径向。渐变角度 (°)(−180° 至 +180°,默认 0°)可旋转任意非径向渐变,正值为顺时针。选择 频率 时,Notes、Guitar 和 Chroma Spiral 还支持 完整音域 或 一个八度 颜色映射。

开启优先使用 MIDI时,Notes和Guitar的颜色模式还可选择通道颜色。其配色与 MIDI 键盘的通道模式相同,颜色排列便于区分相邻通道。没有 MIDI 数据或关闭 MIDI 优先时,使用颜色中设置的单色。

动画与效果

可为任意项目或背景添加视觉效果并调整顺序,塑造理想的画面风格:

  • Opacity、Glow、Outline、Blur、Trail、Scale Pulse、Symmetry、Shake、Particles、Ken Burns(适用于封面/视频/背景图片)、Flash(背景)以及 Backplate(在项目后方绘制可自定义的底板,支持 填充颜色、填充不透明度、边框颜色、边框粗细、圆角半径 和 边距)。
  • Edge Fade:将项目边缘平滑过渡为透明,支持 矩形(可分别设置 顶部、底部、左、右 淡出宽度,0–100%)或 圆形(淡出宽度,0–100%)(默认:上下 10%,左右 0%,圆形 20%),且始终在最后一步应用;项目范围之外的内容也会被隐藏。
  • Transform:围绕项目或背景的中心进行缩放(水平缩放 / 垂直缩放,0–300%,默认 100% 即不变)、倾斜(水平倾斜(°) / 垂直倾斜(°),−60° 至 +60°)、旋转(旋转角度(°),−180° 至 +180°;正值为顺时针)和平移(水平偏移 / 垂直偏移,−100% 至 +100%;正值向右或向下)。倾斜、旋转和平移默认均为 0。
  • Trail Feedback:对叠加的残影回声进行缩放(缩放,−2% 至 +2%,默认 +2%;正值放大)、旋转(旋转角度(°),−3° 至 +3°,默认 1.15°;正值为顺时针)和漂移(水平流动 / 垂直流动,−1% 至 +1%,默认 0%;正值向右或向下)。

视觉效果既可保持恒定,也可随 Time、整体音量 Level,或代表低频、中频和高频强度的 Bass、Mid、Treble 动态响应。Beat 按检测到的节拍间隔平滑地变强、变弱,Width 则随声音向左右扩展的程度变化。强度(0–1)设置效果的强弱:对 Opacity 而言即项目的可见程度(1 为完全可见);对 Transform 而言,0 表示不改变项目,1 表示完全应用设置;对 Trail Feedback 而言,0 时缩放、旋转和漂移停止,只留下短暂的残影。响应幅度 设置 所选调节来源使效果偏离 强度 的程度,速度 设置由 Time 驱动的变化循环的快慢。如果动画帧率下降,可降低 画质 或设为 Auto。

Color Adjust 与 Color Map

Color Adjust 用于调整封面或视频的颜色,Color Map 则根据图像亮度重新分配颜色。两者都适用于项目和背景。强度控制原图(0)与完整效果(1,默认值)的混合比例,也可以用上述调制设置让这个比例随时间或音乐变化。

Color Adjust 的初始设置不会改变图像:

  • 亮度(−100~100%,默认 0)使图像变暗或变亮。对比度(0~300%,默认 100%)增强或减弱明暗差异。饱和度(0~300%,默认 100%)调整颜色的鲜艳程度,0 为灰度图像。色相(−180~180°,默认 0°)旋转颜色。
  • 展开高级设置可调整色阶和白平衡。输入黑场(0~99%,默认 0%)与输入白场(1~100%,默认 100%)指定原图中哪些亮度被视为黑色与白色。提高输入黑场会加深暗部,降低输入白场会提亮亮部;超出此范围的细节会丢失。输入黑场必须低于输入白场。伽马(0.1~4,默认 1)调整中间调,调高变亮,调低变暗。
  • 输出黑场与输出白场(0~100%,默认分别为 0% 和 100%)设置处理结果的两端亮度:提高输出黑场可让暗部变淡,降低输出白场可让白色变暗。交换两端数值会反转明暗关系。色温(−100~100%,默认 0)为正时偏暖红色,为负时偏冷蓝色。色调校正(范围相同)为正时偏品红,为负时偏绿色。反转颜色反转各颜色通道,默认关闭。

若想让歌词背后的背景更柔和,可从饱和度 60%、亮度 −15% 开始。若想看清较暗的封面,又不想明显抬高黑色,可尝试伽马 1.2。

Color Map 按照从暗到亮的顺序分配调色板颜色,默认使用从黑到白的连续调色板。可以编辑色标或应用预设,用反转渐变颠倒颜色顺序,并使用现有的颜色运动设置制作动画。色阶数可选平滑过渡的连续,或 2~16 个离散色阶。选择 2 阶时,阈值(0~100%,默认 50%)将图像分为暗部和亮部,并分别映射为两种颜色;调高会让更多区域使用分配给暗部的颜色。制作双色海报效果时,可选择深蓝到金色的调色板及 2 阶,再调整阈值以保留主体。若只想轻柔地着色,可选连续并降低强度。

预设、分享、备份与显示设置

使用预设对话框可保存、重新加载、重命名或删除命名布局;内置预设始终可用。设置 > 备份 / 恢复 会备份已保存的 Visualizer 预设及其背景图片,但不包含当前正在编辑的布局。

点击工具栏中的 分享 可复制当前布局的分享链接(链接不包含背景图片;如需连同图片迁移请使用 备份 / 恢复)。在桌面应用或浏览器扩展中,复制分享链接后点击 导入链接,或在 Visualizer 中按 Ctrl+V(Mac 上为 ⌘V)即可导入。导入的布局会直接替换当前布局,不会进行确认;如需恢复,请打开 Edit 并选择 撤销。

在 设置 > 配置… 中启用 将画面与音频同步 可使画面与扬声器输出保持对齐;为保持同步,音频可能会被延迟。如果图表没有反应,请确认 音频设置 中的 使用 WebAssembly 音频处理 已开启,且音频正在通过 EffeTune 播放。

设置 > 配置… > 显示 中的 Visualizer HDR 默认关闭。若要在兼容的 HDR 显示器上呈现更明亮的高光,请先在操作系统中启用 HDR,再启用此选项。浏览器或桌面应用以及图形硬件也必须支持 HDR 输出。无法使用 HDR 输出的显示器会自动以 SDR 显示。此设置适用于整个 Visualizer 和纯净输出,会保存在当前设备上,不包含在预设或分享链接中。

显示问题排查

← 返回 README